Pegelanzeige mit LM393

Das Labor ist der richtige Ort um spezielle Projekte inkl. Fehlersuche zu diskutieren.

Moderator: kubi

Pegelanzeige mit LM393

Postby hardtrail » Wed Nov 11, 2015 10:44 pm

Ich habe eine Vorverstärkerplatine für ein ICE-Power Modul gebaut. Mittlerweile habe ich die zweite Prototypen-PCB in den Sand gesetzt und zwar in den grün / rot leuchtenden Halbleitersand. Soll heißen, ich schaffe es einfach nicht, eine Pegelanzeige zu bauen :scratch:
Folgendes ist der Plan:
Das Signal durchläuft hinter den XLR Buchsen einen THAT1240, wird dort desymmetriert, über ein Poti mehr schlecht als Recht variabel laut und dann gehts schon über einen Puffer-OPV an die Endstufenmodule.
nach dem Poti greife ich mir das Signal ab um mir den Pegel anzeigen zu lassen.
Meine Schaltung dazu ist hier Image

Nun die Realität:
In der ersten Version habe ich schonmal die Komperatoren gegrillt. Grund war, dass ich nirgends das Signal gleichrichte und die Teile ab -0,3V sterben.
Daher nun ein Dioden-Feuerwerk am Eingang. Was in meiner LTSpice Simulation nicht zu sehen war, ist dass der Spannungsabfall an den 10k Eingangswiderständen so oß ist, dass ich bei 2VAC Eingang nur 400mVAC an den Komperatoreingängen habe.
Ich vermute, das hängt damit zusammen, dass das Signal ja ein AC Signal ist und die Dioden jedesmal von Leitend in nicht-leitend umgeladen werden müssen. Ich weiß et nicht aber so wie es jetzt ist, ist es Müll.
Weiterhin habe ich die pos/neg Eingänge der Kompressoren vertauscht aber das ist schnell korrigiert.
Hat jemand Anregungen, wie ich diese Pegelanzeige so hinbekomme, dass ich zwei Pegel (grün = Signal da; rot = zu viel Signal) anzeigen kann? Gibts eine Art aktive Gleichrichtung? Ach, ich würde natürlich gerne auf weitere aktive Bauteile verzichten wenn möglich. Ansonsten bliebe ja noch ein Addierer, der mir einen Offset erzeugt und das Signal um x V anhebt.
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes

Re: Pegelanzeige mit LM393

Postby mch » Thu Nov 12, 2015 8:57 pm

Servus Stefan,

wenn das eh eine Endstufe wird, hast Du doch "hinten raus" Pegel ohne Ende. Da hab ich meistens einfach
eine LED, eine (normale) Diode und eine Zenerdiode in Reihe mit einem Poti geschaltet und letzteres so hingedreht,
dass die LED knapp vorm Verzerren ordentlich geleuchtet hat. Vollwellengleichrichter ist fuer Messgeraete. :P

Das Gleiche koennte man mit der "Signal da"-LED machen, muss aber dafuer sorgen, dass man die bei Vollgas
ned grillt ;-)

Beim Pollin gibts uebrigens ganz billige Bausaetze fuer Akkuspannungswaechter mit drei LEDs und Transistorstufen.
Da kannst Du Dir mal die Beschreibung durchlesen. Evtl. kann man die auch umdimensionieren, dann ist es ned
gar so eine Holzhammerloesung wie meine...

Gruesse
Michael
mch
 
Posts: 356
Joined: Wed Sep 07, 2011 7:00 pm
Location: München

Re: Pegelanzeige mit LM393

Postby hardtrail » Fri Mar 25, 2016 3:04 pm

Moin Michael,

jo, mittlerweile ist die Schaltung in der dritten Iteration und die Anzeige läuft. Was im Übrigen gegen deine Idee mit der LED und Poti spricht, ist die Tatsche, dass das Endstufenmodul ein zugekauftes Modul ist. Ich möchte dort keine Schaltung an den Lautsprecheranschlüssen bauen. Daher läuft alles über die Eingangsplatine, die ich mit Vorverstärkern, Poti und eben diesen Level-LEDs ausgestattet habe. Akustische Messungen sind sehr gut, THD1k unter 0,001 und der Frequenzgang wie berechnet ziemlich gerade mit leichtem Abfall ab 10kHz (weniger als 0,5dB bei 20k, Kunde wünscht es so)

Um nochmal zum Thema dieses Threads zurück zu kommen:
Ich habein diesem Endstufenprojekt noch das Problem, dass die Level-LEDs ziemlich früh angehen, abhängig Signal. Ein Bisschen Gehirnschmalz und klar, ich werte dort ja das PEAK-Level aus und keinen RMS Wert.
Da ich nun kurz vor dem ersten Prototypen eines Mikrofon-Per-Amps auf THAT 1512 und 1646 Basis stehe (Schaltung muss "nur" noch geroutet werden) wird mich hier natürlich das selbe Problem ereilen.
Was mache ich in diesem Falle?
Ich sehe mehrere Möglichkeiten:
1. Ich berücksichtige in meinen Level-Metern einen Crest Faktor (wie hoch, 12dB?)
2. Ich baue ein weiteres IC ein, dass mir einen RMS Wert ausgibt (wenig gern, die Beschaltung empfinde ich grad als nicht so intuitiv...)

Wie löst ihr sowas? Gibt es einen "anerkannten" Weg oder sollte ich alle Widerstände für den Komperator mit neuen Schwellen neu berechnen?

EDIT: Ich habe jetzt frei nach GL3000 einen aktiven (ein-Wege) Gleichrichter verbaut und glätte 10ms. Ich bin mal gespannt, ob es in der Praxis tut
hardtrail
 
Posts: 282
Joined: Thu Feb 12, 2009 4:27 pm
Location: Germany, Köln Nippes


Return to Das Labor

Who is online

Users browsing this forum: No registered users and 2 guests

cron